SEG hosted dashboards not accessible for some

Incident Report for GoSecure

Resolved

Carrier routing issues caused dashboards to be accessible intermittently, we are working with the carrier to have proper route redundancy.
Posted Sep 13, 2025 - 15:16 PDT

Monitoring

A fix has been implemented by our provider.
Posted Sep 12, 2025 - 14:23 PDT

Identified

Our provider has routing issues.
Posted Sep 12, 2025 - 11:35 PDT
This incident affected: Hosted Email Security.