Periodic Mail Delivery Interruptions

Incident Report for GoSecure

Resolved

Systems fully operational.
Posted Mar 20, 2025 - 16:52 PDT

Update

We are continuing to monitor for any further issues.
Posted Mar 20, 2025 - 16:51 PDT

Monitoring

We have a resolution in place and mail delivery is normal for the past 1 hour. Removed a node with errors in the mail path that was causing the delays, this resolution should be permanent, but we continue to monitor.
Posted Mar 20, 2025 - 15:02 PDT

Investigating

We have identified an issue causing mail delivery delays on a subset of customer domains, we are implementing a workaround.
Posted Mar 20, 2025 - 13:23 PDT
This incident affected: Hosted Email Security.