Intermittent SEG Personal and Administrator Dashboard access

Incident Report for GoSecure

Resolved

Dashboards are stable however we will continue to monitor.
Posted Mar 31, 2025 - 15:53 PDT

Update

We are continuing to monitor for any further issues.
Posted Mar 31, 2025 - 11:00 PDT

Monitoring

We have a fix implemented and are monitoring the dashboards. They should be functional for Administration and Personal SPAM Quarantine at this time.
Posted Mar 31, 2025 - 11:00 PDT

Investigating

The issue is being addressed, we have identified a possible cause, dashboard access remains intermittent. Mail-flow is not affected, just administration and quarantine.
Posted Mar 31, 2025 - 09:46 PDT
This incident affected: Hosted Email Security.