Microsoft 365 Issue Affecting Mail Flow and MS Apps

Incident Report for GoSecure

Resolved

Microsoft reports a he issue is resolved, mail flow is looking normal for Microsoft 365 clients.
Posted Jan 22, 2026 - 22:16 PST

Update

We are seeing improvements in mail delivery, however Microsoft is not yet considering the issue resolved. Please see MO1221364 for additional information.
Posted Jan 22, 2026 - 20:02 PST

Monitoring

Microsoft is experiencing an outage detailed in the service center as MO1221364 affecting multiple apps. Mail that arrives in our servers will spool for the configured duration on the domain settings.

IDR submissions depend on Outlook accessibility which may also be affected.
Posted Jan 22, 2026 - 11:45 PST
This incident affected: Hosted Email Security and Inbox Detection and Response.